1. What should I do if my iOS app certification expires?

                                                                    

Issue encountered 

Expiry of iOS app certification


Possible causes

After successful creation of the provisional certificate, the expiry date gets generated.

    

Resolution     

Contact  your IT help desk to resolve this issue, which entails creation of new certificates and resigning the application with the new certificate.


Procedure to regenerate a new app store Distribution Provisioning profile


For further help, please reach us at our Customer Product Support Help Desk Portal (https://helpdesk.innovapptive.com) and raise a ticket by providing the required details.



2. What do I need to do if my app crashes?                                                                                                                                                                                                                                                             

Issue encountered 

Encountering an unexpected crash of an app.


Possible causes

It could be either/all of the reasons (Android platform):

  • App is not compatible with the OS version of the device.
  • Device is running out of memory.
  • Bug in the code 


Resolution

  1. Please kill and restart the application
  2. Generate the crash report as outlined in the procedures below and send to helpdesk@innovapptive.com

    

iOS


On Windows Laptop 

    

To create and save crash logs, please follow the steps below, but before that ensure that you have iTools installed on your device:

  1. Install iTools on your Windows laptop.
  2. Launch iTools and connect your iPhone with the laptop via a USB cable. You will be able to see your iPhone listed as an attached device.
  3. Click Advanced and then click System Logs. This opens the Log window.
  4. Perform the operation i.e. from login till the app crashes and then save the log file.





Please share the device logs (crash logs). 


Android

    

Navigate to Storage Location/My Files -> Application Folder > Log cat.txt      


                                                                                                   

      


For further help, please reach us at our Customer Product Support Help Desk Portal 

(https://helpdesk.innovapptive.com) and raise a ticket by providing the required details.



3. How can I change my connection settings in an application?  


1. On the Login screen of the application that you want to access, tap the Settings icon (available at the top corner).



2. In the Settings screen, update with respective settings and tap on save settings tab.

  • SMP Server Host 
  • Server Port 
  • Application ID defined in SMP 
  • Security Profile assigned to App in SMP 


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